The State of XIoT Security Report: 1H 2022
Download the Report
Team82 Logo Claroty Logo
High Threat

CVE-2022-25903

opcua is an OPC UA server / client API implementation for Rust. Affected versions of this package are vulnerable to Denial of Service (DoS) via the ExtensionObjects and Variants objects, when it allows unlimited nesting levels, which could result in a stack overflow even if the message size is less than the maximum allowed.

Risk Information

CVE ID

CVE-2022-25903

Vendor

OPC UA Rust

Product

OPC UA Rust package

CVSS v3

7.5


Disclosure Policy

Team82 is committed to privately reporting vulnerabilities to affected vendors in a coordinated, timely manner in order to ensure the safety of the cybersecurity ecosystem worldwide. To engage with the vendor and research community, Team82 invites you to download and share our Coordinated Disclosure Policy. Team82 will adhere to this reporting and disclosure process when we discover vulnerabilities in products and services.

Public Email & PGP Key

Team82 has also made its public PGP Key available for the vendor and research community to securely and safely exchange vulnerability and research information with us.

Claroty Logo
LinkedIn Twitter Facebook