CVE-2021-23278

IMPROPER INPUT VALIDATION CWE-20
Eaton Intelligent Power Manager (IPM) prior to 1.69 is vulnerable to an authenticated arbitrary file delete vulnerability induced due to improper input validation at server/maps_srv.js with the “removeBackground” function and server/node_upgrade_srv.js with the “removeFirmware” function. An attacker can send specially crafted packets to delete the files on the system where IPM software is installed.

Risk Information

  • CVE ID
  • CVE-2021-23278
  • Vendor
  • Eaton
  • Product
  • Eaton Intelligent Power Manager
  • CVSS v3
  • 8.7